Gamestudio Links
Zorro Links
Newest Posts
Trailing on Ticks
by danatrader. 07/12/20 04:35
Misreading Monitor Resolution
by Dooley. 07/11/20 23:42
Help with Martingale Script
by Qw3rty. 07/11/20 12:17
Help with code
by Qw3rty. 07/11/20 12:03
Tick Volume
by danatrader. 07/11/20 06:43
FAC Train mode
by danatrader. 07/10/20 18:13
A9
by 3run. 07/09/20 19:13
AUM Magazine
Latest Screens
The Space Between
Pogostuck: Rage With Your Friends
Worst Case Z
AckCon'18 - Lotter vs the World 2 - Preview Release
Who's Online Now
6 registered members (Quad, Iglarion, ChrstphFr, kvm, ozgur, AndrewAMD), 362 guests, and 5 spiders.
Key: Admin, Global Mod, Mod
Newest Members
dasanc, DavidFdez, TraderKevin, deus777, carolthesecond
18476 Registered Users
Previous Thread
Next Thread
Print Thread
Rate Thread
Page 2 of 2 1 2
Re: Running R from a zorro script. [Re: jcl] #459183
04/26/16 10:27
04/26/16 10:27
Joined: Jul 2000
Posts: 27,256
Frankfurt
jcl Offline

Chief Engineer
jcl  Offline

Chief Engineer

Joined: Jul 2000
Posts: 27,256
Frankfurt
Before applying the debug viewer, here's something else to try. Please download this:

http://server.conitec.net/down/include.zip

It contains a new r.h include file. Please replace the old one with it and try again. Tell me how this works.

Re: Running R from a zorro script. [Re: jcl] #459184
04/26/16 10:31
04/26/16 10:31
Joined: Apr 2016
Posts: 10
J
JackSturgeon Offline OP
Newbie
JackSturgeon  Offline OP
Newbie
J

Joined: Apr 2016
Posts: 10
This is the output from debugview:

[9348] installed exception handler for C:\Program Files (x86)\Zorro\mt4R.DLL
[9348] <0> Create: Failed to execute C : 2
[9348] <0> Create: Error: R did not start: 2
[9348] RInit: RHandle = BD8E63C (198764092)
[9348] RDeinit: RHandle = BD8E63C (198764092)
[9348] <-1> TRConsole: destroying

Especially this line:

[9348] <0> Create: Failed to execute C : 2

seems interesting

Re: Running R from a zorro script. [Re: JackSturgeon] #459185
04/26/16 10:36
04/26/16 10:36
Joined: Jul 2000
Posts: 27,256
Frankfurt
jcl Offline

Chief Engineer
jcl  Offline

Chief Engineer

Joined: Jul 2000
Posts: 27,256
Frankfurt
Thanks! The "2" confirms my suspicion. Can you try with the new r.h?

Re: Running R from a zorro script. [Re: jcl] #459189
04/26/16 11:51
04/26/16 11:51
Joined: Apr 2016
Posts: 10
J
JackSturgeon Offline OP
Newbie
JackSturgeon  Offline OP
Newbie
J

Joined: Apr 2016
Posts: 10
How do I get the new r.h?

I only know the one in the include directory.

Re: Running R from a zorro script. [Re: JackSturgeon] #459191
04/26/16 12:06
04/26/16 12:06
Joined: Jul 2000
Posts: 27,256
Frankfurt
jcl Offline

Chief Engineer
jcl  Offline

Chief Engineer

Joined: Jul 2000
Posts: 27,256
Frankfurt
Look at my post above.

Re: Running R from a zorro script. [Re: jcl] #459203
04/26/16 19:10
04/26/16 19:10
Joined: Apr 2016
Posts: 10
J
JackSturgeon Offline OP
Newbie
JackSturgeon  Offline OP
Newbie
J

Joined: Apr 2016
Posts: 10
The new r.h did the trick.

It works now as expected.

Zorro 1.42.2 Trading Automaton
Made with Gamestudio by oP group 2015


RTest compiling.................
0 10 20 30 40

Thanks a lot. I can start digging around now. ;-)

Re: Running R from a zorro script. [Re: JackSturgeon] #479609
04/10/20 15:39
04/10/20 15:39
Joined: Aug 2017
Posts: 30
Netherlands
G
Grant Offline
Newbie
Grant  Offline
Newbie
G

Joined: Aug 2017
Posts: 30
Netherlands
Greetings,

I experience similar issues, while running Zorro 2.25 with R 3.6.2 on Wine. I can't run the RTest script properly:

Code
RTest compiling.............. ok
C:\Program Files\R\R-3.6.2\bin\x64\RTerm.exe  --no-save
R initialized!

R stopped!


Things, I've tried to far:
- Tried two types of RTermPath's in zorro.ini, "C:\Program Files\R\R-3.6.2\bin\x64\RTerm.exe" and "/home/administrator/.wine/drive_c/Program Files/R/R-3.6.2/bin/x64/RTerm.exe".
- Reinstalled both Zorro and R.

When I run DebugView while running the script, it returns:

Code
[38] <2> Create: trying to start R: C:\Program Files\R\R-3.6.2\bin\x64\RTerm.exe  --no-save
[38] <0> Create: Failed to execute C:\Program Files\R\R-3.6.2\bin\x64\RTerm.exe  --no-save : 5
[38] <0> Create: Error: R did not start: 5
[38] RInit: RHandle = 25A1904 (39459076)
[38] RDeinit: RHandle = 25A1904 (39459076)
[38] <-1> TRConsole: destroying


FYI, I'm able to run a RTerm instance manually.

Cheers,

Grant





Last edited by Grant; 04/10/20 15:40.
Re: Running R from a zorro script. [Re: JackSturgeon] #479611
04/10/20 17:53
04/10/20 17:53
Joined: Dec 2014
Posts: 173
Germany
Smon Offline
Member
Smon  Offline
Member

Joined: Dec 2014
Posts: 173
Germany
Try R version 3.5.3

There have been compatibility problems with deep learning libraries with more recent functions half a year ago. I stopped hunting the newest R version since then.

Re: Running R from a zorro script. [Re: Smon] #479637
04/13/20 14:55
04/13/20 14:55
Joined: Aug 2017
Posts: 30
Netherlands
G
Grant Offline
Newbie
Grant  Offline
Newbie
G

Joined: Aug 2017
Posts: 30
Netherlands
Thank you for your suggestion, Smon. Unfortunately downgrading my R version resulted in the same problem.

I was able to run RTest successfully after installing Zorro and R in a Crossover environment. For whatever reason it's not possible to run the 64 bit version of Rterm.exe (tested in multiple 64 bit 'bottles' in Crossover), but the 32-bit version works fine.

BTW, a nice benefit of Crossover over Wine is that the visual appearance of Zorro is still fine after minimizing its window.

Grant

Last edited by Grant; 04/13/20 15:05.
Page 2 of 2 1 2

Moderated by  Petra 

Powered by UBB.threads™ PHP Forum Software 7.7.1