Gamestudio Links
Zorro Links
Newest Posts
file_write var array ?
by laz. 10/22/19 16:00
SAV_STATS
by MatPed. 10/22/19 13:57
Instrument Price Zorro Chart
by jcl. 10/22/19 10:39
Accessing All Historical Price Data
by jcl. 10/22/19 10:37
Calculating with price series
by AndrewAMD. 10/21/19 14:31
Error E355: Startup failure
by Dooley. 10/21/19 06:47
Today real live account blown - my experience
by Clifford_B. 10/19/19 17:09
AUM Magazine
Latest Screens
The Space Between
Pogostuck: Rage With Your Friends
Worst Case Z
AckCon'18 - Lotter vs the World 2 - Preview Release
Who's Online Now
14 registered members (JamesHH, AndrewAMD, alibaba, jenGs, FLD, jyd, MatPed, Dalla, 3 invisible), 672 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
Newest Members
VillageTalkies, line7, Shutch, Clifford_B, Paulius
18310 Registered Users
Previous Thread
Next Thread
Print Thread
Rate Thread
Page 2 of 2 1 2
Re: Z12 Test: Error 040: Inconsistent optimize calls [Re: SnoopySniff] #477770
07/26/19 20:25
07/26/19 20:25
Joined: Oct 2018
Posts: 77
S
SnoopySniff Offline OP
Junior Member
SnoopySniff  Offline OP
Junior Member
S

Joined: Oct 2018
Posts: 77
I just checked the results of Zorro 1.96 and 2.03. It's the same like the newest versions. It's just creating one par-file. I never realized that. So it's not the version and not the script. It's me! But what is wrong with my perception. Hmmmm.

Re: Z12 Test after Train --> Error 040: Inconsistent optimize calls [Re: SnoopySniff] #477771
07/26/19 21:16
07/26/19 21:16
Joined: Oct 2018
Posts: 77
S
SnoopySniff Offline OP
Junior Member
SnoopySniff  Offline OP
Junior Member
S

Joined: Oct 2018
Posts: 77
This are the assetlists I am using for FBS, RoboForex (RF) and IC Markets (ICM). All of them are alright in my eyes.

Attached Files
assetlists_fbs_rf.png (18 downloads)
AssetList from FBS and RoboForex (RF)
assetlist_ICM.png (11 downloads)
AssetList from IC Markets (ICM)
Re: Z12 Test after Train --> Error 040: Inconsistent optimize calls [Re: SnoopySniff] #477772
07/26/19 21:18
07/26/19 21:18
Joined: Oct 2018
Posts: 77
S
SnoopySniff Offline OP
Junior Member
SnoopySniff  Offline OP
Junior Member
S

Joined: Oct 2018
Posts: 77
I made some tests and documented them in the attached excel sheet.

Starting point of my trouble (problem summary): I am trying to get the Z12 script running with a cent account from RoboForex and got persistently "Error 040: Wrong XAG/USD:ES optimize calls!" as feedback, when I ran a test. I tried the Zorro versions 1.96, 2.03 and 2.15.3 with the included version of the Z12 script and got his error with all of them.

At last I tried different confiugrations with the Zorro Version 2.15.3. I found out, when I add the CFD's to the AssetList, even I can't trade them with this cent account, and don't exculde them in the INI-File, I don't get the "Error 040: Wrong XAG/USD:ES optimize calls!". I don't find this logic, but I can live with it as trades for CFD's can't be opened in live trading. But it feels like a bug.

Thank you for helping me thinking this through. I appreciate it.

PS: As you may noticed in the excel sheet, I tried the asset.ist from my ECN Account of IC Markets were I don't have any trouble with the test. Just to make sure that the assetlist itself is not the reason for the problem.
PSS: The cent account from FBS is impacted as well.

Attached Files
Last edited by SnoopySniff; 07/28/19 20:25.
Re: Z12 Test after Train --> Error 040: Inconsistent optimize calls [Re: SnoopySniff] #477799
07/29/19 20:00
07/29/19 20:00
Joined: Oct 2018
Posts: 77
S
SnoopySniff Offline OP
Junior Member
SnoopySniff  Offline OP
Junior Member
S

Joined: Oct 2018
Posts: 77
When nobody is answering I totally understand it. I think i can live with it. Cheers.

Re: Z12 Test after Train --> Error 040: Inconsistent optimize calls [Re: SnoopySniff] #477804
07/30/19 06:36
07/30/19 06:36
Joined: Jul 2000
Posts: 27,033
Frankfurt
jcl Offline

Chief Engineer
jcl  Offline

Chief Engineer

Joined: Jul 2000
Posts: 27,033
Frankfurt
I don't know the details of a cent account, but believe that you must at least multiply Pip cost and possibly margin cost with 100. The error messages hint that something else is also wrong. Replace your .par files with the originals and double check the asset list.

Re: Z12 Test after Train --> Error 040: Inconsistent optimize calls [Re: SnoopySniff] #477824
07/31/19 18:11
07/31/19 18:11
Joined: Oct 2018
Posts: 77
S
SnoopySniff Offline OP
Junior Member
SnoopySniff  Offline OP
Junior Member
S

Joined: Oct 2018
Posts: 77
Unfortunately not the effect I was hoping for. But it's alright. In live trading the cent accounts are performing positiv. I will have an eye on it. One made since Novemeber 2018 already 50% profit and the other is live since a week and at 4% profit. Little gifts to my friends... laugh

Re: Z12 Test after Train --> Error 040: Inconsistent optimize calls [Re: SnoopySniff] #478105
09/07/19 19:37
09/07/19 19:37
Joined: Oct 2018
Posts: 77
S
SnoopySniff Offline OP
Junior Member
SnoopySniff  Offline OP
Junior Member
S

Joined: Oct 2018
Posts: 77
I found out that the swaps were not correct in the asset lists when using a cent account. I manually calculated and compared the swaps in MT4 with the ones when backtesting. Basically I needed to multiply the swaps with 0.01 and corrected them in the assetlists and since then the results are fine.

Attached Files
Page 2 of 2 1 2

Gamestudio download | chip programmers | Zorro platform | shop | Data Protection Policy

oP group Germany GmbH | Birkenstr. 25-27 | 63549 Ronneburg / Germany | info (at) opgroup.de

Powered by UBB.threads™ PHP Forum Software 7.7.1