Gamestudio Links
Zorro Links
Newest Posts
Using ":L" & ":S" causes 2 possible bug(s) or is it bad coding?
by AndrewAMD
8 minutes 26 seconds ago
Help with Data import to T1
by OptimusPrime
Today at 19:44
How to ensamble multiple algos with advise calls?
by laz
Today at 18:53
Correlation -1.#IND00
by AndrewAMD
01/21/19 17:37
Basic thread safety question
by Superku
01/20/19 18:15
Blog Post: Get Historical Data from Darwinex REST API w/ Zorro
by AndrewAMD
01/19/19 22:19
Reseting a static variable - the next day
by OptimusPrime
01/19/19 19:48
AUM Magazine
Latest Screens
Worst Case Z
AckCon'18 - Lotter vs the World 2 - Preview Release
Evonet Beta v1.0 : Online Project Development Template
Lake scene
Who's Online
12 registered (OptimusPrime, AndrewAMD, jacek, Dalla, kvm, Quad, Iglarion, ibne, misiek, 3 invisible), 489 Guests and 7 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
jthbln, laz, ramonne, SibJac, Evael
18157 Registered Users
Topic Options
Rate This Topic
#474760 - 11/04/18 23:37 Broker Uses # symbol prior to indice symbol - Assetlist
djhenry1981 Offline
Guest

Registered: 09/15/18
Posts: 4
Loc: VIC
Hi,

I've got an issue with a new broker, It's indices begin with #, however when I the symbol in Assetlist to accomodate this, Zorro doesnt detect this change. I've tried putting in quotes EG "#DAX" and checked the manual but cant find how i fix this issue.

Example of DAX30 is as follows in my Assetlist
Name Price Spread RollLong RollShort PIP PIPCost MarginCost Leverage LotAmount Commission Symbol
DAX30 12348.9 1 -0.0845 -0.117 0.1 0.011747 7.253 200.01 0.1 0 #DAX30


Edited by djhenry1981 (11/04/18 23:39)

Top
#474765 - 11/05/18 09:52 Re: Broker Uses # symbol prior to indice symbol - Assetlist [Re: djhenry1981]
jcl Offline

Chief Engineer

Registered: 07/22/00
Posts: 26694
Loc: Frankfurt
Old Zorro versions interpreted the '#' as a comment character, so make sure you use the latest version.

Top
#474821 - 11/07/18 16:35 Re: Broker Uses # symbol prior to indice symbol - Assetlist [Re: jcl]
Mio Offline
Newbie

Registered: 10/19/18
Posts: 16
1.88 does not support symbol prefix of #
You can try 1.94 and 1.96
But I still meet problems in fxopen
Zorro can load price but cannot trade with the prefix #

Top
#474849 - 11/09/18 11:27 Re: Broker Uses # symbol prior to indice symbol - Assetlist [Re: Mio]
jcl Offline

Chief Engineer

Registered: 07/22/00
Posts: 26694
Loc: Frankfurt
I confirm that. This will be fixed in 1.96.

Top
#474866 - 11/10/18 02:51 Re: Broker Uses # symbol prior to indice symbol - Assetlist [Re: jcl]
Mio Offline
Newbie

Registered: 10/19/18
Posts: 16
Originally Posted By: jcl
I confirm that. This will be fixed in 1.96.

FxOpen(including symbol#) can work in 1.96 now. I will keep tracking

Top



Gamestudio download | chip programmers | Zorro platform | shop | Data Protection Policy

oP group Germany GmbH | Birkenstr. 25-27 | 63549 Ronneburg / Germany | info (at) opgroup.de