Gamestudio Links
Zorro Links
Newest Posts
Issue with Starter Window
by txesmi. 10/23/19 09:22
Accessing All Historical Price Data
by JohnJits. 10/22/19 22:37
file_write var array ?
by laz. 10/22/19 16:00
SAV_STATS
by MatPed. 10/22/19 13:57
Instrument Price Zorro Chart
by jcl. 10/22/19 10:39
Calculating with price series
by AndrewAMD. 10/21/19 14:31
Error E355: Startup failure
by Dooley. 10/21/19 06:47
AUM Magazine
Latest Screens
The Space Between
Pogostuck: Rage With Your Friends
Worst Case Z
AckCon'18 - Lotter vs the World 2 - Preview Release
Who's Online Now
10 registered members (AndrewAMD, Uhrwerk, jenGs, MatPed, kvm, 20BN, Paulius, Dalla, 2 invisible), 635 guests, and 5 spiders.
Key: Admin, Global Mod, Mod
Newest Members
Bolle, VillageTalkies, line7, Shutch, Clifford_B
18311 Registered Users
Previous Thread
Next Thread
Print Thread
Rate Thread
Broker Arbitrage setup #477713
07/24/19 11:30
07/24/19 11:30
Joined: May 2019
Posts: 10
S
sarmasboy Offline OP
Newbie
sarmasboy  Offline OP
Newbie
S

Joined: May 2019
Posts: 10
I'm trying to set up your broker arbitrage script to work using the instructions noted in the manual (https://manual.zorro-project.com/brokerarb.htm), but I'm getting errors (Zorro and MT4 screenshots attached):
[Linked Image]
[Linked Image]

Here's what my Accounts.csv looks like:
Name,Broker,Account,User,Pass,Assets,CCY,Real,NFA,Plugin,Source
FXCM,FXCM,0,D25724363,xxxx,AssetsArb,EUR,0,0,FXCM.dll,
DWX,MT4,0,2088954273,xxxx,AssetsArb,EUR,0,0,ZorroMT4.dll

Here's my AssetsArb.csv:
Name,Price,Spread,RollLong,RollShort,PIP,PIPCost,MarginCost,Leverage,LotAmount,Commission,Symbol
EUR/USD_A,1.13239,0.00004,-1.21,0.69,0.0001,0.1,0,30.003,1000,0.3,DWX:EUR/USD
EUR/USD_B,1.1014,0.00006,-1.03,0.34,0.0001,0.1,13,0,1000,0.6,FXCM:EUR/USD

Any idea why it is not picking up the prices from the brokers? If I run different scripts using the same account details, they connect fine.

Attached Files
image.png (639 downloads)
image (1).png (643 downloads)
Last edited by sarmasboy; 07/24/19 11:31.
Re: Broker Arbitrage setup [Re: sarmasboy] #477714
07/24/19 11:45
07/24/19 11:45
Joined: May 2019
Posts: 10
S
sarmasboy Offline OP
Newbie
sarmasboy  Offline OP
Newbie
S

Joined: May 2019
Posts: 10
Sorry I was missing the DWX:EUR/USD!DWX:EUR/USD in the Symbol, which fixed the FXCM bug. However I still have the same Zorro error. Now my AssetsArb.csv file looks like this:

Name,Price,Spread,RollLong,RollShort,PIP,PIPCost,MarginCost,Leverage,LotAmount,Commission,Symbol
EUR/USD_A,1.13239,0.00004,-1.21,0.69,0.0001,0.1,0,30.003,1000,0.3,DWX:EUR/USD!DWX:EUR/USD
EUR/USD_B,1.1014,0.00006,-1.03,0.34,0.0001,0.1,13,0,1000,0.6,FXCM:EUR/USD!FXCM:EUR/USD


Gamestudio download | chip programmers | Zorro platform | shop | Data Protection Policy

oP group Germany GmbH | Birkenstr. 25-27 | 63549 Ronneburg / Germany | info (at) opgroup.de

Powered by UBB.threads™ PHP Forum Software 7.7.1