Gamestudio Links
Zorro Links
Newest Posts
Any Old Timers Still Around?
by pyramide. 08/24/19 18:23
Script filename
by MatPed. 08/24/19 17:18
Oanda FIFO issue?
by AndrewAMD. 08/24/19 12:10
IG plugin initial release
by Dalla. 08/24/19 06:06
Tutorial for Vector Graphics
by Dooley. 08/23/19 22:32
Issue with dataParse function
by byakuren81. 08/23/19 21:57
Multiplayer subscription
by Truth. 08/23/19 20:08
candle pattern on weekly bars
by AndrewAMD. 08/23/19 13:20
AUM Magazine
Latest Screens
The Space Between
Pogostuck: Rage With Your Friends
Worst Case Z
AckCon'18 - Lotter vs the World 2 - Preview Release
Who's Online Now
8 registered members (pyramide, 3run, AndrewAMD, MatPed, byakuren81, Realspawn, 2 invisible), 644 guests, and 7 spiders.
Key: Admin, Global Mod, Mod
Newest Members
Ysbail, trader4321, GorgonzolaBYTE, Southqvist, tawin
18272 Registered Users
Previous Thread
Next Thread
Print Thread
Rate Thread
Setting GPU when training on Zorro #477909
08/13/19 15:38
08/13/19 15:38
Joined: Apr 2019
Posts: 30
Albay
M
marr Offline OP
Newbie
marr  Offline OP
Newbie
M

Joined: Apr 2019
Posts: 30
Albay
Hi guys i have a deep learning script in R which GPU is enabled when training, it took only few minutes to complete the whole dataset to train. When i run it with Zorro it seems to use the CPU since it takes hours to finish up training. Is there any way to switch to GPU when training on Zorro?

Re: Setting GPU when training on Zorro [Re: marr] #477915
08/13/19 20:40
08/13/19 20:40
Joined: Feb 2017
Posts: 742
Chicago
AndrewAMD Online
User
AndrewAMD  Online
User

Joined: Feb 2017
Posts: 742
Chicago
Zorro supports GPU training via R.

Your setup needs to be correct. Either you failed to get your GPU to work, or you created a bottleneck. But it is impossible to identify the culprit with what little context you have provided.

Re: Setting GPU when training on Zorro [Re: marr] #477919
08/14/19 05:24
08/14/19 05:24
Joined: Apr 2019
Posts: 30
Albay
M
marr Offline OP
Newbie
marr  Offline OP
Newbie
M

Joined: Apr 2019
Posts: 30
Albay
i am using conda env on my R to load the tensorflow gpu, and my the script is similar to zorro example. my gpu is 1051ti 4gb, cpu is i3-4170 3.7GHz
cpu bottle neck is possible culprit, my goal is to make zorro training run as fast as i run on R console using gpu

the code that i use to load conda env

Code
use_condaenv("r-dl", required=T)

Last edited by marr; 08/14/19 05:24.
Re: Setting GPU when training on Zorro [Re: marr] #477920
08/14/19 11:40
08/14/19 11:40
Joined: Feb 2017
Posts: 742
Chicago
AndrewAMD Online
User
AndrewAMD  Online
User

Joined: Feb 2017
Posts: 742
Chicago
I haven't used Tensorflow directly (I've used Keras->Tensorflow), but I believe there is a way to verify which processing unit you are using. Confirm your processing unit, both via R and then via Zorro->R.

Re: Setting GPU when training on Zorro [Re: marr] #477921
08/14/19 12:11
08/14/19 12:11
Joined: Apr 2019
Posts: 30
Albay
M
marr Offline OP
Newbie
marr  Offline OP
Newbie
M

Joined: Apr 2019
Posts: 30
Albay
I mean I am using Keras with Tensorflow GPU and able to confirm that on R terminal, I don't know how to verify from Zorro->R

Re: Setting GPU when training on Zorro [Re: marr] #477922
08/14/19 12:52
08/14/19 12:52
Joined: Feb 2017
Posts: 742
Chicago
AndrewAMD Online
User
AndrewAMD  Online
User

Joined: Feb 2017
Posts: 742
Chicago
How about the same way you did in the R terminal?

Re: Setting GPU when training on Zorro [Re: marr] #477929
08/15/19 06:18
08/15/19 06:18
Joined: Apr 2019
Posts: 30
Albay
M
marr Offline OP
Newbie
marr  Offline OP
Newbie
M

Joined: Apr 2019
Posts: 30
Albay
the way i did in R terminal is when I run the neura.test() it has a info message the it detects the gpu and using it and fast when training. but the process is slow when i click Train on zorro panel and theres no message that it use gpu, only shows cpu the number of cpu cores in use


Gamestudio download | chip programmers | Zorro platform | shop | Data Protection Policy

oP group Germany GmbH | Birkenstr. 25-27 | 63549 Ronneburg / Germany | info (at) opgroup.de

Powered by UBB.threads™ PHP Forum Software 7.7.1