Gamestudio Links
Zorro Links
Newest Posts
The Black Book
by SteveG. 06/06/20 14:01
Indicator coding
by danatrader. 06/06/20 11:53
New AUM
by Aku_Aku. 06/06/20 10:10
Reading a TXT file on server
by Truth. 06/05/20 18:22
Oanda instruments
by Morris. 06/05/20 10:24
MT4/5 - wrong M1 time
by Grat. 06/05/20 08:34
AUM Magazine
Latest Screens
The Space Between
Pogostuck: Rage With Your Friends
Worst Case Z
AckCon'18 - Lotter vs the World 2 - Preview Release
Who's Online Now
8 registered members (AndrewAMD, SteveG, Mio, 3run, Iglarion, danatrader, Grat, 1 invisible), 473 guests, and 4 spiders.
Key: Admin, Global Mod, Mod
Newest Members
Frank_Shieh, PBSeven, Hardi01, Giuseppe, AdamWu
18461 Registered Users
Previous Thread
Next Thread
Print Thread
Rate Thread
IB: GET_POSITION is sometimes invalid? #477962
08/19/19 18:41
08/19/19 18:41
Joined: Feb 2017
Posts: 983
Chicago
AndrewAMD Online OP
User
AndrewAMD  Online OP
User

Joined: Feb 2017
Posts: 983
Chicago
jcl,

With the IB plugin, GET_POSITION sometimes returns 0, even when a nonzero position exists! Apparently it returns 0 to indicate that there was a problem! So if it ever returns 0, I cannot rely on the output.

Perhaps the IB plugin can support a new command, GET_POSITIONISVALID? It indicates whether the previous GET_POSITION call output was an actual position or not. 0: not supported. 1: call was valid. 2: previous call resulted in an error.

This would be especially useful for pool management.

Thanks,
Andrew

Re: IB: GET_POSITION is sometimes invalid? [Re: AndrewAMD] #477963
08/20/19 08:14
08/20/19 08:14
Joined: Jul 2000
Posts: 27,225
Frankfurt
jcl Offline

Chief Engineer
jcl  Offline

Chief Engineer

Joined: Jul 2000
Posts: 27,225
Frankfurt
That command would probably not help much. If GET_POSITION wrongly returns 0, then GET_POSITIONISVALID could also wrongly return 1, due to the same error.

It is better to find out what error that was. For which assets does GET_POSITION return a wrong value and under which circumstances?

Re: IB: GET_POSITION is sometimes invalid? [Re: AndrewAMD] #477972
08/20/19 10:52
08/20/19 10:52
Joined: Feb 2017
Posts: 983
Chicago
AndrewAMD Online OP
User
AndrewAMD  Online OP
User

Joined: Feb 2017
Posts: 983
Chicago
Good question, I do not know if I can repeat the issue. There was one time where I was still connected, but every single GET_POSITION in my stock portfolio was returning 0 when there should have been positions. At least I think I was connected.

I will see if it comes up again.


Moderated by  Petra 

Gamestudio download | chip programmers | Zorro platform | shop | Data Protection Policy

oP group Germany GmbH | Birkenstr. 25-27 | 63549 Ronneburg / Germany | info (at) opgroup.de

Powered by UBB.threads™ PHP Forum Software 7.7.1