Gamestudio Links
Zorro Links
Newest Posts
Can't plot daily high & low
by Junker. 10/13/19 23:51
Imgui Lite-c Development
by txesmi. 10/13/19 09:40
A9
by Dooley. 10/11/19 18:53
Need Help Finding Cause of Crash
by Dooley. 10/11/19 18:51
What algorithm is used for BALANCED?
by JamesHH. 10/11/19 17:32
Votes for future features
by AndrewAMD. 10/11/19 14:12
Price not shown correctly via MT4 bridge
by gamadeus. 10/10/19 05:48
Loading Keybindings from a File
by Dooley. 10/10/19 03:44
AUM Magazine
Latest Screens
The Space Between
Pogostuck: Rage With Your Friends
Worst Case Z
AckCon'18 - Lotter vs the World 2 - Preview Release
Who's Online Now
5 registered members (Michael_Schwarz, YG8, kvm, JamesHH, 1 invisible), 637 guests, and 7 spiders.
Key: Admin, Global Mod, Mod
Newest Members
FrankW, TedMar, raimucuk, vivaldi2, filip
18304 Registered Users
Previous Thread
Next Thread
Print Thread
Rate Thread
MT4 bridge from 2.15 no work #477477
07/01/19 15:11
07/01/19 15:11
Joined: May 2015
Posts: 163
Czech Republic
Grat Offline OP
Member
Grat  Offline OP
Member

Joined: May 2015
Posts: 163
Czech Republic
Hi,

I update from 2.12 up to 2.15 and cannot connect MT4
Quote


ai_eu_dtree2 compiling..................
Login 0 MT4/5..
!Can't initialize bridge!
Check account number xxxxxx
Can't connect!


I update plugin from install. EA have version 2.06 and dll 1.15

account number and password I wrote correct ( double check )

Last edited by Grat; 07/01/19 15:12.
Re: MT4 bridge from 2.15 no work [Re: Grat] #477478
07/01/19 15:19
07/01/19 15:19
Joined: Feb 2017
Posts: 768
Chicago
AndrewAMD Online
User
AndrewAMD  Online
User

Joined: Feb 2017
Posts: 768
Chicago
Did you update and recompile the MT4 Expert Advisor too?

Re: MT4 bridge from 2.15 no work [Re: Grat] #477480
07/01/19 17:16
07/01/19 17:16
Joined: Feb 2017
Posts: 358
D
Dalla Offline
Senior Member
Dalla  Offline
Senior Member
D

Joined: Feb 2017
Posts: 358
Per the release notes: "The MT4/MT5 bridge was changed in 2.15. Re-install the bridge and re-compile the Zorro EA."

Re: MT4 bridge from 2.15 no work [Re: Grat] #477482
07/01/19 17:42
07/01/19 17:42
Joined: Jul 2000
Posts: 27,024
Frankfurt
jcl Offline

Chief Engineer
jcl  Offline

Chief Engineer

Joined: Jul 2000
Posts: 27,024
Frankfurt
The new bridge is probably not the problem. But for some reason, people often succeed installing the bridge the first time, but fail the second time. Maybe they forgot to compile the EA or did not find the right folder. If you find out what it was in your case, please let us know.

Re: MT4 bridge from 2.15 no work [Re: Grat] #477483
07/01/19 17:54
07/01/19 17:54
Joined: Feb 2017
Posts: 768
Chicago
AndrewAMD Online
User
AndrewAMD  Online
User

Joined: Feb 2017
Posts: 768
Chicago
For the record, it works for me.

When in doubt, delete the MT4 EA and start over.
[Linked Image]

Attached Files
works.PNG (235 downloads)
Re: MT4 bridge from 2.15 no work [Re: Grat] #477484
07/01/19 20:34
07/01/19 20:34
Joined: May 2015
Posts: 163
Czech Republic
Grat Offline OP
Member
Grat  Offline OP
Member

Joined: May 2015
Posts: 163
Czech Republic
Ok,

after clear install MT4 bridge work. Problem is only if upgrade from 1.96

Re: MT4 bridge from 2.15 no work [Re: Grat] #478032
08/28/19 01:23
08/28/19 01:23
Joined: Aug 2019
Posts: 1
S
sinergymy Offline
Guest
sinergymy  Offline
Guest
S

Joined: Aug 2019
Posts: 1
Hi. I have the same problem. I have the MT4 build 1170. Does anyway has the Zorro 2.15 working with MT4 1170? I checked the dll in the Library folder and it is old (from 2017). Is that correct?
Thank you so much for helping!

Re: MT4 bridge from 2.15 no work [Re: Grat] #478038
08/28/19 19:03
08/28/19 19:03
Joined: Feb 2017
Posts: 358
D
Dalla Offline
Senior Member
Dalla  Offline
Senior Member
D

Joined: Feb 2017
Posts: 358
If you read the release notes, you will find that "The MT4/MT5 bridge was changed in 2.15. Re-install the bridge and re-compile the Zorro EA."
https://zorro-trader.com/manual/en/new.htm


Gamestudio download | chip programmers | Zorro platform | shop | Data Protection Policy

oP group Germany GmbH | Birkenstr. 25-27 | 63549 Ronneburg / Germany | info (at) opgroup.de

Powered by UBB.threads™ PHP Forum Software 7.7.1