Gamestudio Links
Zorro Links
Newest Posts
Can't plot daily high & low
by Zheka. 10/14/19 18:39
TWS "Market closed" fix
by jcl. 10/14/19 15:09
2xCapital slider to increase size
by jcl. 10/14/19 14:03
Imgui Lite-c Development
by txesmi. 10/13/19 09:40
A9
by Dooley. 10/11/19 18:53
Need Help Finding Cause of Crash
by Dooley. 10/11/19 18:51
What algorithm is used for BALANCED?
by JamesHH. 10/11/19 17:32
AUM Magazine
Latest Screens
The Space Between
Pogostuck: Rage With Your Friends
Worst Case Z
AckCon'18 - Lotter vs the World 2 - Preview Release
Who's Online Now
7 registered members (exile, Dooley, Dalla, kvm, sdh309795gaas, jibanes, Zheka), 661 guests, and 6 spiders.
Key: Admin, Global Mod, Mod
Newest Members
FrankW, TedMar, raimucuk, vivaldi2, filip
18304 Registered Users
Previous Thread
Next Thread
Print Thread
Rate Thread
Price not shown correctly via MT4 bridge #478353
10/08/19 20:55
10/08/19 20:55
Joined: Nov 2018
Posts: 50
G
gamadeus Offline OP
Junior Member
gamadeus  Offline OP
Junior Member
G

Joined: Nov 2018
Posts: 50
When trading via MT4 bridge I have the problem that Zorro cannot display the balance correctly.

An example would be something like this in Hedge 5

[Tue 19-10-08 19:00] 9891 +0.0091120 +2.60 / (1.09490)
{EUR/USD:MAXL_EU_t_1:s4601} Stop 1@1.09620: +1.44 at 19:00:12
[EUR/USD:NET:S3707] Cover 1@0.0: +0.0091229 at 19:00:12

The virtual trade ilooks fine, but the pool trade does not. The number it shows does not make any sense at all to me.
Its the same for other Hedge modes, I just display virtual and pool side by side to illustrate the problem.

Anybody knows how to fix this?

Last edited by gamadeus; 10/10/19 05:46.
Re: Balance not shown correctly via MT4 bridge [Re: gamadeus] #478360
10/09/19 08:26
10/09/19 08:26
Joined: Jul 2000
Posts: 27,029
Frankfurt
jcl Offline

Chief Engineer
jcl  Offline

Chief Engineer

Joined: Jul 2000
Posts: 27,029
Frankfurt
I see no wrong balance in your log, but a wrong price. Make sure that you installed the MT4 bridge correctly. The support had recently a case where a user had the bridge put together from different old Zorro versions, and that caused exactly such a problem.

Re: Balance not shown correctly via MT4 bridge [Re: gamadeus] #478378
10/10/19 05:48
10/10/19 05:48
Joined: Nov 2018
Posts: 50
G
gamadeus Offline OP
Junior Member
gamadeus  Offline OP
Junior Member
G

Joined: Nov 2018
Posts: 50
Ah yes, you are right on both counts! Its not the balance but the price (sorry for confusing these) and the installed MT4 dll file was obsolete for version 2.15. Now everything works like a charm.
Thanks jcl!


Gamestudio download | chip programmers | Zorro platform | shop | Data Protection Policy

oP group Germany GmbH | Birkenstr. 25-27 | 63549 Ronneburg / Germany | info (at) opgroup.de

Powered by UBB.threads™ PHP Forum Software 7.7.1