Gamestudio Links
Zorro Links
Newest Posts
IG plugin initial release
by sodiumchloride. 09/22/20 20:53
Using STL in Zorro strategies
by AndrewAMD. 09/22/20 17:01
Rubbish data from Yahoo
by DanielX. 09/22/20 14:37
assert
by Grat. 09/22/20 12:14
MT4 - use more Zorro script
by Grat. 09/22/20 06:49
Single advise model for portfolio
by jmlocatelli. 09/21/20 19:41
AUM Magazine
Latest Screens
The Space Between
Pogostuck: Rage With Your Friends
Worst Case Z
AckCon'18 - Lotter vs the World 2 - Preview Release
Who's Online Now
4 registered members (Dooley, kvm, AndrewAMD, jmlocatelli), 445 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Newest Members
NewBorn, 3dvg, secretagentman, distribution, EditeY
18515 Registered Users
Previous Thread
Next Thread
Print Thread
Rate Thread
problem with adding new history #481090
08/06/20 11:52
08/06/20 11:52
Joined: Jul 2020
Posts: 11
D
daan Offline OP
Newbie
daan  Offline OP
Newbie
D

Joined: Jul 2020
Posts: 11
hey.
I did try to convert this type of csv
[Linked Image]
usnig CSVtoHistory with this format
[Linked Image]
and I did tried to add it to the history slider by adding it to assetfix with this format
[Linked Image]
and at the end when I was running the script I came into this problem
[Linked Image]

any idea?

Last edited by daan; 08/06/20 11:56.
Re: problem with adding new history [Re: daan] #481102
08/06/20 16:25
08/06/20 16:25
Joined: Jul 2000
Posts: 27,343
Frankfurt
jcl Offline

Chief Engineer
jcl  Offline

Chief Engineer

Joined: Jul 2000
Posts: 27,343
Frankfurt
The timestamp format is wrong.

Re: problem with adding new history [Re: jcl] #481109
08/06/20 19:53
08/06/20 19:53
Joined: Jul 2020
Posts: 11
D
daan Offline OP
Newbie
daan  Offline OP
Newbie
D

Joined: Jul 2020
Posts: 11
Originally Posted by jcl
The timestamp format is wrong.

I aslo used this format
[Linked Image]
but it still got the same error.

Re: problem with adding new history [Re: daan] #481113
08/07/20 02:17
08/07/20 02:17
Joined: Apr 2008
Posts: 320
Austria
Petra Offline
Support
Petra  Offline
Support

Joined: Apr 2008
Posts: 320
Austria
Thats 2015 but the error was for 2019?

You can look in the t6 file with the history script or history viewer and see whats wrong.

Re: problem with adding new history [Re: Petra] #481119
08/07/20 08:29
08/07/20 08:29
Joined: Jul 2020
Posts: 11
D
daan Offline OP
Newbie
daan  Offline OP
Newbie
D

Joined: Jul 2020
Posts: 11
Originally Posted by Petra
Thats 2015 but the error was for 2019?

You can look in the t6 file with the history script or history viewer and see whats wrong.

The data is from 2015 to 2020.
it tells me history script is for zorro S. is ther any other way to view the t6 file?

Re: problem with adding new history [Re: daan] #481121
08/07/20 08:41
08/07/20 08:41
Joined: Mar 2019
Posts: 249
D
danatrader Online
Member
danatrader  Online
Member
D

Joined: Mar 2019
Posts: 249

Last edited by danatrader; 08/07/20 08:42.
Re: problem with adding new history [Re: daan] #481127
08/07/20 10:06
08/07/20 10:06
Joined: Jul 2020
Posts: 11
D
daan Offline OP
Newbie
daan  Offline OP
Newbie
D

Joined: Jul 2020
Posts: 11
there was a mistake in string format and I fixed it and I also change the data format to this:
[Linked Image]
but it still show if like this
https://pasteboard.co/Jlg0y4x.png

Last edited by daan; 08/07/20 11:56.
Re: problem with adding new history [Re: daan] #481129
08/07/20 10:57
08/07/20 10:57
Joined: Jul 2000
Posts: 27,343
Frankfurt
jcl Offline

Chief Engineer
jcl  Offline

Chief Engineer

Joined: Jul 2000
Posts: 27,343
Frankfurt
Looks like still a wrong format string. Is it really semicolon separated?

Re: problem with adding new history [Re: jcl] #481140
08/07/20 12:36
08/07/20 12:36
Joined: Jul 2020
Posts: 11
D
daan Offline OP
Newbie
daan  Offline OP
Newbie
D

Joined: Jul 2020
Posts: 11
Originally Posted by jcl
Looks like still a wrong format string. Is it really semicolon separated?

this is the csv format
[Linked Image]
this is the string format im using in csvtohistory
[Linked Image]

Re: problem with adding new history [Re: daan] #481178
08/10/20 14:27
08/10/20 14:27
Joined: Jul 2000
Posts: 27,343
Frankfurt
jcl Offline

Chief Engineer
jcl  Offline

Chief Engineer

Joined: Jul 2000
Posts: 27,343
Frankfurt
The format string looks better now, but there is still something wrong - in the sample that you posted, the Low seems to be higher than the Open.

If you can't get it to work, you can contact Support. We have a data conversion service.


Moderated by  Petra 

Powered by UBB.threads™ PHP Forum Software 7.7.1