Gamestudio Links
Zorro Links
Newest Posts
How to: plot a frequency spectrum in bars?
by Sempervirens. 05/12/21 02:45
Backtest accuracy
by AndrewAMD. 05/12/21 00:26
Test one asset with more bar period in one run
by AndrewAMD. 05/12/21 00:22
System with more take profit
by AndrewAMD. 05/12/21 00:20
EXANTE broker
by madpower2000. 05/11/21 17:02
No Trades when Backtesting Period is longer
by TimmiHendrix. 05/11/21 15:47
Last Candle for Testing and Train?
by jcl. 05/11/21 12:14
DataSplit for Advise
by TimmiHendrix. 05/11/21 10:40
AUM Magazine
Latest Screens
Hecknex World
Scheherazade's Journey
Paradox Vector
The Space Between
Who's Online Now
3 registered members (AndrewAMD, Sempervirens, jyd), 470 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Newest Members
ShadowAx, TimmiHendrix, contactmmfx, msupl7, Robert_
18644 Registered Users
Previous Thread
Next Thread
Print Thread
Rate Thread
[SOLVED]Strange problem - new Hardware bad framerate #483090
05/03/21 21:27
05/03/21 21:27
Joined: Jul 2008
Posts: 2,022
Germany
rayp Offline OP

X
rayp  Offline OP

X

Joined: Jul 2008
Posts: 2,022
Germany
Hi.

I have a strange problem. My graphic card broke. It was a old 1GB card.

Now i realize, even the shadeC evo demo scene only runs with 50fps in window mode (800x600).
I started my old computer (15 years old). With a ATI Radeon HD4800 (old). The shadeC evo demo scene runs with over 250fps.

I dont have ANY idea why the hell shadeC now only runs with 30fps in fullscreen. It happend with my onboard-graphic-chip and with two other cards i tested (NVIDIA GT520, GT610 1GB).

How is it possible that the shadeC demo scene only runs with 30fps in fullscreen now ?

Any idea what happend to my computer ? DxDiag shows no erros.
If i would not use 3dgs with shadeC possibly i would have never noticed this. But now this drives me crazy cause i was working heavy on my project. Then the card broke. From that day on i have only 30fps in the shadeC demo scene.


It would be nice if anybody has an idea what strange thing made a empty shadeC app run with 30-50fps.

edit: All cards are shown in 3dgs startup window, all drivers are fresh from nvidia. But no matter what i do, the same scene that runs on my old hardware with 250fps now only runs with 30-50fps on my new computer.

Windows 10 is used


I downloaded a app called FurMark to test the GPU. I guess its not normal that this test only runs with 5fps. So what happened to my system? No matter what GPU i build in i get slow framerates as it seams.

Last edited by rayp; 05/04/21 21:52.

Acknex umgibt uns...zwischen Dir, mir, dem Stein dort...
"Hey Griswold ... where u gonna put a tree that big ?"
1998 i married my loved wife ... Sheeva from Mortal Kombat, not Evil-Lyn as might have been expected
rayp.flags |= UNTOUCHABLE;
Re: Strange problem - new Hardware bad framerate [Re: rayp] #483093
05/03/21 22:11
05/03/21 22:11
Joined: Jul 2008
Posts: 2,022
Germany
rayp Offline OP

X
rayp  Offline OP

X

Joined: Jul 2008
Posts: 2,022
Germany
Is a >15 years old ATI HD4800 so much better than a GT610 ? I know the GT610 is not a gaming card...but can it make a difference of 200fps in the exact same (shadec demo) scene ?

Edit: it took me years to have good framerates in my games...now the empty demo scenes running with 50fps in window 800x600...i cant imagine the hd4800 is that much better. So now iam curious what to do. Use my stoneold pc to have good framerate while testing, this cant be true. Is it Win10 - acknex? Or because iam using two screens? i dont have any idea why all the systems i used in the last 10 years had better framerates in 3dgs. Never seen the demo scene with less than 200 frames in window mode before.


I noticed the "ref" in the f11-info-panel is about 20ms. On my old pc its about 2. Over 20ms isnt normal right ?

Anybody else noticed a strange speed drop in 3dgs? Cause i dont feel like its hardware related. More like the OS or something limits 3dgs to 50%.

Last edited by rayp; 05/03/21 23:53.

Acknex umgibt uns...zwischen Dir, mir, dem Stein dort...
"Hey Griswold ... where u gonna put a tree that big ?"
1998 i married my loved wife ... Sheeva from Mortal Kombat, not Evil-Lyn as might have been expected
rayp.flags |= UNTOUCHABLE;
Re: Strange problem - new Hardware bad framerate [Re: rayp] #483106
05/04/21 09:14
05/04/21 09:14
Joined: May 2009
Posts: 5,326
Caucasus
3run Offline
Senior Expert
3run  Offline
Senior Expert

Joined: May 2009
Posts: 5,326
Caucasus
Hey!

Originally Posted by rayp
I downloaded a app called FurMark to test the GPU. I guess its not normal that this test only runs with 5fps. So what happened to my system? No matter what GPU i build in i get slow framerates as it seams.
It's normal, this just means that GPU is very weak. With FurMark the only things that can prove that there is something wrong with GPU is:
Quote
1 - artifacts;
2 - overheat;
3 - PC shutdown/driver failure.

I'm not familiar with any of those GPUs, but googling shows up that HD4800 is indeed faster than GT610 (faster memory -> GDDR5 vs GDDR3 and 1,000.0 gflops vs 155.5 gflops).

Originally Posted by rayp
I noticed the "ref" in the f11-info-panel is about 20ms. On my old pc its about 2. Over 20ms isnt normal right ?
Quote
ref - time for screen refresh, monitor sync, and fps_max idling.
You probably need to upgrade the GPU, looks like GT610 can't pull the shade-c graphics, OR you need to think of a way to optimize the graphics.
Anyway, sharing debug panel with all the specs when you have fps drop might help.


Greets.


Looking for free stuff?? Take a look here: http://badcom.at.ua
Re: Strange problem - new Hardware bad framerate [Re: rayp] #483108
05/04/21 15:28
05/04/21 15:28
Joined: Jul 2008
Posts: 2,022
Germany
rayp Offline OP

X
rayp  Offline OP

X

Joined: Jul 2008
Posts: 2,022
Germany
Thanks a lot for ur reply man.

I thought a card from 2012 with 1gb must be better than a card from 2008 with 512mb.

Tonight ill build in the hd4800 and see what happens. If it is below 200fps i know its not gpu related.


Acknex umgibt uns...zwischen Dir, mir, dem Stein dort...
"Hey Griswold ... where u gonna put a tree that big ?"
1998 i married my loved wife ... Sheeva from Mortal Kombat, not Evil-Lyn as might have been expected
rayp.flags |= UNTOUCHABLE;
Re: Strange problem - new Hardware bad framerate [Re: rayp] #483109
05/04/21 16:17
05/04/21 16:17
Joined: Jul 2008
Posts: 2,022
Germany
rayp Offline OP

X
rayp  Offline OP

X

Joined: Jul 2008
Posts: 2,022
Germany
If u have win10 could u just start the evo demo scene to see it works for you? I want to make sure its not windows/update related or something. Thanks

Edit
The 02.c with the car etc

Last edited by rayp; 05/04/21 16:21.

Acknex umgibt uns...zwischen Dir, mir, dem Stein dort...
"Hey Griswold ... where u gonna put a tree that big ?"
1998 i married my loved wife ... Sheeva from Mortal Kombat, not Evil-Lyn as might have been expected
rayp.flags |= UNTOUCHABLE;
Re: Strange problem - new Hardware bad framerate [Re: rayp] #483114
05/04/21 18:39
05/04/21 18:39
Joined: May 2009
Posts: 5,326
Caucasus
3run Offline
Senior Expert
3run  Offline
Senior Expert

Joined: May 2009
Posts: 5,326
Caucasus
Originally Posted by rayp
If u have win10 could u just start the evo demo scene to see it works for you? I want to make sure its not windows/update related or something. Thanks

Edit
The 02.c with the car etc
I've been working under win10 for almost 2 years now (currently 20H2 version), never faced that kind of issues with shade-c. But I was always using modern GPU (rx580, rtx 2060).

Screenshot:
[Linked Image]

Tested this with the shade-c evo from my github (version without memory leaks hopefully).

Greets.


Looking for free stuff?? Take a look here: http://badcom.at.ua
Re: Strange problem - new Hardware bad framerate [Re: rayp] #483118
05/04/21 19:30
05/04/21 19:30
Joined: Jul 2008
Posts: 2,022
Germany
rayp Offline OP

X
rayp  Offline OP

X

Joined: Jul 2008
Posts: 2,022
Germany
I know i already worked with Windows10 too, with no problems.

Ok then i guess my problem really just is a totally weak GPU. ...damn. Still i cant believe a 4 years newer gpu can suck this hard.

Ill send my demoscene to a friend. Iam pretty sure he will have good framerate too, cause hes using a gaming pc (cause he is a gamer laugh )


So until i have a good GPU i will use my 2008 HD4800 lol...crazy. Guess i will mod my two pcs tonight. Changing the GPUs from one to another.

Thanks a lot for the test dude.


Edit: You found the memory leaks ? This is great. Downloading now.


Acknex umgibt uns...zwischen Dir, mir, dem Stein dort...
"Hey Griswold ... where u gonna put a tree that big ?"
1998 i married my loved wife ... Sheeva from Mortal Kombat, not Evil-Lyn as might have been expected
rayp.flags |= UNTOUCHABLE;
Re: Strange problem - new Hardware bad framerate [Re: rayp] #483119
05/04/21 20:15
05/04/21 20:15
Joined: Jul 2008
Posts: 2,022
Germany
rayp Offline OP

X
rayp  Offline OP

X

Joined: Jul 2008
Posts: 2,022
Germany
If i run the dxtex.exe it says unable to create Direct3D device....make sure d3dref.dll is installed and desktop set to 16 or 32 bit. I cant find that dll on my pc(system32+syswow64).

Finally i made a benchmark. It says something like: Your pc rocks! But u dont have any gpu power laugh

Last edited by rayp; 05/04/21 20:58.

Acknex umgibt uns...zwischen Dir, mir, dem Stein dort...
"Hey Griswold ... where u gonna put a tree that big ?"
1998 i married my loved wife ... Sheeva from Mortal Kombat, not Evil-Lyn as might have been expected
rayp.flags |= UNTOUCHABLE;
Re: Strange problem - new Hardware bad framerate [Re: rayp] #483121
05/04/21 21:50
05/04/21 21:50
Joined: Jul 2008
Posts: 2,022
Germany
rayp Offline OP

X
rayp  Offline OP

X

Joined: Jul 2008
Posts: 2,022
Germany
Well now i feel stupid. I found out the GT610 is the last thing u want to have in your pc. I just installed the HD4800 from my old computer into my new computer. After a strange CPU cooler bios error, iam back on my desktop. The 610 is that bad even your onboard chip performs better.

And shadeC runs with 200 fps instead of 50. Wow.
Quote
Ill send my demoscene to a friend. Iam pretty sure he will have good framerate too, cause hes using a gaming pc (cause he is a gamer laugh )
530fps grin and he said he didnt spend that much for the gpu(i correct myself, 500€ is not cheap, but theres open end).

All in all it seams like the stone old Radeon is still not that bad.


Thanks a lot for your help.

Last edited by rayp; 05/05/21 00:48.

Acknex umgibt uns...zwischen Dir, mir, dem Stein dort...
"Hey Griswold ... where u gonna put a tree that big ?"
1998 i married my loved wife ... Sheeva from Mortal Kombat, not Evil-Lyn as might have been expected
rayp.flags |= UNTOUCHABLE;

Moderated by  old_bill, Tobias 

Gamestudio download | chip programmers | Zorro platform | shop | Data Protection Policy

oP group Germany GmbH | Birkenstr. 25-27 | 63549 Ronneburg / Germany | info (at) opgroup.de

Powered by UBB.threads™ PHP Forum Software 7.7.1