Gamestudio Links
Zorro Links
Newest Posts
C++ scripts
by AndrewAMD. 07/02/22 13:02
FXCM doesn't show up in Broker drop-down
by Smallz. 07/02/22 12:32
History & HistoryFolder
by DdlV. 07/01/22 14:57
car.c how to add a trailer or wagon?
by Ice2642. 07/01/22 13:35
IB: brokercommand to cancel **all** orders.
by AndrewAMD. 06/30/22 17:21
Save As dialog box (like file_select)
by jcl. 06/30/22 10:18
AUM Magazine
Latest Screens
DEAD TASTE
Tactics of World War I
Hecknex World
Scheherazade's Journey
Who's Online Now
2 registered members (AndrewAMD, 1 invisible), 446 guests, and 7 spiders.
Key: Admin, Global Mod, Mod
Newest Members
Anas, PeroPero, AlexTomb, BigW, QJSH
18790 Registered Users
Previous Thread
Next Thread
Print Thread
Rate Thread
Live web server not updating #485831
04/27/22 08:12
04/27/22 08:12
Joined: Feb 2022
Posts: 9
London
L
loopiezlol Offline OP
Newbie
loopiezlol  Offline OP
Newbie
L

Joined: Feb 2022
Posts: 9
London
I've been running a Zorro system for almost two months now.

Sometimes I'd run into connectivity issues with IB Gateway, but overall the whole thing worked pretty well.

However, sometimes I notice that the built-in web server reporting stops updating, requiring me to restart the Zorro instance.

In this screenshot you can see how the live status drifted from the HTML report, the former showing updates for the 27th, while the latter stopped on the 26th.
[Linked Image]

I'm wondering if anyone else ran into this issue and figured out how to alleviate it without manual intervention (i.e. restarting whenever it breaks).

Re: Live web server not updating [Re: loopiezlol] #485832
04/27/22 09:24
04/27/22 09:24
Joined: Aug 2017
Posts: 198
Netherlands
G
Grant Offline
Member
Grant  Offline
Member
G

Joined: Aug 2017
Posts: 198
Netherlands
From what I see the disconnection is caused by your first issue: "no security definition..."

Have a look at this documentation: https://interactivebrokers.github.io/tws-api/rtd_fqa_errors.html#rtd_common_errors_no_security

Re: Live web server not updating [Re: loopiezlol] #485844
04/27/22 17:46
04/27/22 17:46
Joined: Apr 2008
Posts: 546
Austria
Petra Offline
Support
Petra  Offline
Support

Joined: Apr 2008
Posts: 546
Austria
Gateway disconnects every Sunday anyway, so you must always restart it on Monday. But you need not restart Zorro, only the Gateway.

Re: Live web server not updating [Re: loopiezlol] #485980
05/20/22 10:03
05/20/22 10:03
Joined: Feb 2022
Posts: 9
London
L
loopiezlol Offline OP
Newbie
loopiezlol  Offline OP
Newbie
L

Joined: Feb 2022
Posts: 9
London
Thanks for the reply Petra and Grant!

I am aware of the IB Gateway restarts. On Sundays I'm manually restarting the gateway, while on the rest of the days I rely on IB Gateway's auto-restart feature.

However, I noticed that sometimes mid-week, Zorro fails to successfully connect to the IB. Usually, this gets resolved the next day, after the restart.

Yet, this week I noticed the behaviour happening 2 days in a row.
[Linked Image]
- on Wednesday 18th, at 12:00 UTC, the IB Gateway restart kicked-in
- seems that Zorro failed to properly connect
- the Live trading status seems to have halted then
- up until the next restart (Thursday 19th) the total Balance stayed constant at 1885. this makes me think Zorro was unable to fetch any updated value

Same thing happened on Thursday 19th:
[Linked Image]
- got the expected IB disconnect at 12:00 UTC (due to Gateway restart)
- this time, there's an extra error on a security "No Data". this seems to happen on a random basis and may not be the root cause of the issue, as the previous connection issue wasn't accompanied by the same error
- you can notice that the IB Gateway "Market Data Farm" and "Historical Data Farm" aren't being used given their red indicator
- likewise, Zorro's Broker connection status is red
- the live status failed to update since Wednesday

Any clues how to further debug this? Is there a verbose flag particularly aimed at broker connectivity?

Re: Live web server not updating [Re: loopiezlol] #485981
05/20/22 11:16
05/20/22 11:16
Joined: Apr 2008
Posts: 546
Austria
Petra Offline
Support
Petra  Offline
Support

Joined: Apr 2008
Posts: 546
Austria
I don't know the reason of the connection problem, but as long as Zorro is not connected, it cannot trade on that account or update the balance.

The software is from IB, so I would not know either how to debug it. Try changing the port,that's the only parameter that you can affect on the Zorro side. Maybe that port is used by another software on your PC, or something like that. Normally the IB connection is very reliable, I have never heard so far of connection issues.

You can manually reconnect Zorro when you click [Stop] and then answer [No] on the requester. Zorro will then log out and log in.



Moderated by  Petra 

Gamestudio download | chip programmers | Zorro platform | shop | Data Protection Policy

oP group Germany GmbH | Birkenstr. 25-27 | 63549 Ronneburg / Germany | info (at) opgroup.de

Powered by UBB.threads™ PHP Forum Software 7.7.1