No, I´m rather concerned about complicated functions like setting the pan angle of an object to a random value.

This seems not to be very intuitive.

Of course everything is object oriented, but it scares me that
such simple functions are cluttered into more than one line:

var temp : GameObject = Instantiate(prefab, position, Random.rotation);
temp.transform.eulerAngles.y = 0;

I prefer "ENTITY.pan = random(360);" - but that´s just me. wink

Edit: Pappenheimer has nailed it pretty well.


no science involved