could you please do something like this:
Code:
public Vector xyz
{
	get
	{
		return Vector.createFromPointer(xPointer);
	}
	set
	{
		Vector.createFromPointer(xPointer).vec_set(value);
	}
}


this would enable us to write better and easier code, because assigning a vector would look like this:
Code:
skyStars.xyz = camera.xyz;


and not like this:
Code:
skyStars.xyz.vec_set(camera.xyz);



EDIT:
And please do not wrap all functions!
I know it was hard work, but wrapping clamp instead of rewriting it is really bad. This solution is much safer and faster:
Code:
public static double clamp(double x, double a, double b)
{
	if (x < a) return a;
	if (x > b) return b;
	return x;
}



also you should use ref/out instead of DoubleSet and those strange variable-setting delegates

another thing to mention is that using read-only properties for stuff like getting entity or bmap properties:
Code:
public int Width
{
	get
	{
		return bmap_width();
	}
}



Last edited by MasterQ32; 07/20/12 18:38. Reason: Additional things

Visit my site: www.masterq32.de