Cool^

Notes - If this is a event, using a naming convention is a good idea. Also, while with a straight -1 you comp works but if you did -7(odd number) it will fail, consider using a <=. If this is a event, check event_type if using many event trigger ENABLE_IMPACT ENABLE_BLOCK ect...

Code:
function remove_brick_evnt() // Naming
{
if(event_type == EVENT_WHATEVER)
{
	my.skill1 -=1;
}
	wait(1);
	if(my.skill1 <=0){
		my.emask &= ~ENABLE_WHATEVER; 
		set(my,PASSABLE | INVISIBLE); // Should not be need and slows removal over all
		//my.event = NULL; // Should not be needed 
		wait(1);
		ent_remove(me);
	}
}



Those are my note - Awesome job, good work.
Mal